summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJames E. King III <jking@apache.org>2019-01-22 14:16:39 -0500
committerJames E. King III <jking@apache.org>2019-01-24 12:20:30 -0500
commitb1d63e7190fb1e4a2d87a9be42f3d4b7f17305fd (patch)
tree1b6d331270e1a4ba53aabd0fb8637a4c85efa5d7 /configure.ac
parent22749ac376b10982eb5fa5a32ba336b20e1e6344 (diff)
downloadthrift-b1d63e7190fb1e4a2d87a9be42f3d4b7f17305fd.tar.gz
THRIFT-4750: as3 changes to build and publish to maven central
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac29
1 files changed, 29 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bdd1dd2a0..a299785fc 100755
--- a/configure.ac
+++ b/configure.ac
@@ -116,6 +116,7 @@ AC_ARG_ENABLE([libs],
have_libs=yes
if test "$enable_libs" = "no"; then
have_libs="no"
+ with_as3="no"
with_cpp="no"
with_c_glib="no"
with_cl="no"
@@ -141,6 +142,18 @@ if test "$enable_libs" = "no"; then
with_swift="no"
fi
+AX_THRIFT_LIB(as3, [as3], yes)
+have_as3=no
+if test "$with_as3" = "yes"; then
+ if test "${FLEX_HOME+set}" = set; then
+ AC_PATH_PROGS([FLEX_COMPC], [compc], "fail", [$PATH$PATH_SEPARATOR$FLEX_HOME/bin])
+ if test "$FLEX_COMPC" != "fail"; then
+ have_as3="yes"
+ fi
+ fi
+fi
+AM_CONDITIONAL(WITH_AS3, [test "$have_as3" = "yes"])
+
AX_THRIFT_LIB(cpp, [C++], yes)
have_cpp=no
if test "$with_cpp" = "yes"; then
@@ -187,6 +200,7 @@ if test "$with_c_glib" = "yes"; then
PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.0], have_glib2=yes, have_glib2=no)
PKG_CHECK_MODULES([GOBJECT], [gobject-2.0 >= 2.0], have_gobject2=yes, have_gobject2=no)
if test "$have_glib2" = "yes" -a "$have_gobject2" = "yes" ; then
+ AC_PATH_PROG([GSETTINGS], [gsettings])
have_c_glib="yes"
fi
fi
@@ -793,6 +807,7 @@ AC_CONFIG_FILES([
compiler/cpp/test/Makefile
compiler/cpp/src/thrift/version.h
lib/Makefile
+ lib/as3/Makefile
lib/cl/Makefile
lib/cpp/Makefile
lib/cpp/test/Makefile
@@ -874,6 +889,8 @@ AC_CONFIG_FILES([
tutorial/rs/Makefile
])
+if test "$have_as3" = "yes" ; then MAYBE_AS3="as3" ; else MAYBE_AS3="" ; fi
+AC_SUBST([MAYBE_AS3])
if test "$have_cpp" = "yes" ; then MAYBE_CPP="cpp" ; else MAYBE_CPP="" ; fi
AC_SUBST([MAYBE_CPP])
if test "$have_c_glib" = "yes" ; then MAYBE_C_GLIB="c_glib" ; else MAYBE_C_GLIB="" ; fi
@@ -923,6 +940,7 @@ AC_OUTPUT
echo
echo "$PACKAGE $VERSION"
echo
+echo "Building ActionScript3 Library : $have_as3"
echo "Building C (GLib) Library .... : $have_c_glib"
echo "Building C# (Mono) Library ... : $have_csharp"
echo "Building C++ Library ......... : $have_cpp"
@@ -946,6 +964,17 @@ echo "Building Ruby Library ........ : $have_ruby"
echo "Building Rust Library ........ : $have_rs"
echo "Building Swift Library ....... : $have_swift"
+if test "$have_as3" = "yes" ; then
+ echo
+ echo "ActionScript Library:"
+ echo " FLEX_HOME ................. : $FLEX_HOME"
+ echo " Using compc version ....... : $($FLEX_COMPC --version)"
+fi
+if test "$have_c_glib" = "yes" ; then
+ echo
+ echo "C (glib):"
+ echo " Using glib version ........ : $($GSETTINGS --version)"
+fi
if test "$have_csharp" = "yes" ; then
echo
echo "C# Library:"