summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRoger Meier <roger@apache.org>2015-11-14 10:08:33 +0100
committerRoger Meier <roger@apache.org>2015-11-14 17:24:11 +0100
commitc7b3086665b5b10f7cbcf3adae850e45c9ed6c02 (patch)
tree5b536dabe8ff1cfffa76d7495657bcbe63e034e1 /configure.ac
parentd80d0b214372d22bd92801039cc5a2a09a227d4e (diff)
downloadthrift-c7b3086665b5b10f7cbcf3adae850e45c9ed6c02.tar.gz
THRIFT-3421 rebar as dependency instead of bundling
This closes #693
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 777300a10..37f19c99a 100755
--- a/configure.ac
+++ b/configure.ac
@@ -233,13 +233,14 @@ AX_THRIFT_LIB(erlang, [Erlang], yes)
if test "$with_erlang" = "yes"; then
AC_ERLANG_PATH_ERL
AC_ERLANG_PATH_ERLC
+ AC_PATH_PROG([REBAR], [rebar])
if test -n "$ERLC" ; then
AC_ERLANG_SUBST_LIB_DIR
# Install into the detected Erlang directory instead of $libdir/erlang/lib
ERLANG_INSTALL_LIB_DIR="$ERLANG_LIB_DIR"
AC_ERLANG_SUBST_INSTALL_LIB_SUBDIR(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
fi
- if test -n "$ERL" -a -n "$ERLC" ; then
+ if test -n "$ERL" -a -n "$ERLC" && test "x$REBAR" != "x" ; then
have_erlang="yes"
# otp_release is simply a number (like "17") for OTP17+ while "R16..." for OTP16 or less.
@@ -897,6 +898,7 @@ if test "$have_erlang" = "yes" ; then
echo
echo "Erlang Library:"
echo " Using erlc ................ : $ERLC"
+ echo " Using rebar ............... : $REBAR"
fi
if test "$have_go" = "yes" ; then
echo