summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJens Geyer <jensg@apache.org>2021-02-13 15:05:40 +0100
committerJens Geyer <jensg@apache.org>2021-02-14 11:18:01 +0100
commitcb094b80f2b5a6752063124a50c05f070e95c7a7 (patch)
tree1497c3192cf7ab81cb71495192125053aa4568db /configure.ac
parentb51a62b9686bad1db949735025ca6823c3c8462b (diff)
downloadthrift-cb094b80f2b5a6752063124a50c05f070e95c7a7.tar.gz
THRIFT-5229 remove AS3 support
Client: AS3 Patch: Jens Geyer This closes #2329
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac23
1 files changed, 0 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index 608c4aa5e..a70a812f8 100755
--- a/configure.ac
+++ b/configure.ac
@@ -116,7 +116,6 @@ AC_ARG_ENABLE([libs],
have_libs=yes
if test "$enable_libs" = "no"; then
have_libs="no"
- with_as3="no"
with_cpp="no"
with_c_glib="no"
with_cl="no"
@@ -141,18 +140,6 @@ if test "$enable_libs" = "no"; then
with_swift="no"
fi
-AX_THRIFT_LIB(as3, [as3], yes)
-have_as3=no
-if test "$with_as3" = "yes"; then
- if test "${FLEX_HOME+set}" = set; then
- AC_PATH_PROGS([FLEX_COMPC], [compc], "fail", [$PATH$PATH_SEPARATOR$FLEX_HOME/bin])
- if test "$FLEX_COMPC" != "fail"; then
- have_as3="yes"
- fi
- fi
-fi
-AM_CONDITIONAL(WITH_AS3, [test "$have_as3" = "yes"])
-
AX_THRIFT_LIB(cpp, [C++], yes)
have_cpp=no
if test "$with_cpp" = "yes"; then
@@ -776,7 +763,6 @@ AC_CONFIG_FILES([
compiler/cpp/src/Makefile
compiler/cpp/test/Makefile
lib/Makefile
- lib/as3/Makefile
lib/cl/Makefile
lib/cpp/Makefile
lib/cpp/test/Makefile
@@ -857,8 +843,6 @@ AC_CONFIG_FILES([
tutorial/rs/Makefile
])
-if test "$have_as3" = "yes" ; then MAYBE_AS3="as3" ; else MAYBE_AS3="" ; fi
-AC_SUBST([MAYBE_AS3])
if test "$have_cpp" = "yes" ; then MAYBE_CPP="cpp" ; else MAYBE_CPP="" ; fi
AC_SUBST([MAYBE_CPP])
if test "$have_c_glib" = "yes" ; then MAYBE_C_GLIB="c_glib" ; else MAYBE_C_GLIB="" ; fi
@@ -906,7 +890,6 @@ AC_OUTPUT
echo
echo "$PACKAGE $VERSION"
echo
-echo "Building ActionScript3 Library : $have_as3"
echo "Building C (GLib) Library .... : $have_c_glib"
echo "Building C++ Library ......... : $have_cpp"
echo "Building Common Lisp Library.. : $have_cl"
@@ -928,12 +911,6 @@ echo "Building Ruby Library ........ : $have_ruby"
echo "Building Rust Library ........ : $have_rs"
echo "Building Swift Library ....... : $have_swift"
-if test "$have_as3" = "yes" ; then
- echo
- echo "ActionScript Library:"
- echo " FLEX_HOME ................. : $FLEX_HOME"
- echo " Using compc version ....... : $($FLEX_COMPC --version)"
-fi
if test "$have_c_glib" = "yes" ; then
echo
echo "C (glib):"