summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJens Geyer <jensg@apache.org>2022-03-05 18:15:38 +0100
committerJens Geyer <Jens-G@users.noreply.github.com>2022-03-06 14:58:37 +0100
commitd88d4f93b3390989bd47a43f3941ca7d576750f6 (patch)
tree15192fecdaefc7c811fda1783368ffe1ce036d3e /configure.ac
parent66ac7b46fab85f175aec601cb48ea05408a1c186 (diff)
downloadthrift-d88d4f93b3390989bd47a43f3941ca7d576750f6.tar.gz
THRIFT-5501 Remove Common Lisp support
Client: cl Patch: Jens Geyer
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac23
1 files changed, 0 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index 1ab550ab0..5181f60ad 100755
--- a/configure.ac
+++ b/configure.ac
@@ -112,7 +112,6 @@ if test "$enable_libs" = "no"; then
have_libs="no"
with_cpp="no"
with_c_glib="no"
- with_cl="no"
with_java="no"
with_python="no"
with_py3="no"
@@ -422,16 +421,6 @@ if test "$with_rs" = "yes"; then
fi
AM_CONDITIONAL(WITH_RS, [test "$have_rs" = "yes"])
-AX_THRIFT_LIB(cl, [Common Lisp], yes)
-have_cl="no"
-if test "$with_cl" = "yes"; then
- AC_PATH_PROG([SBCL], [sbcl])
- if test "x$SBCL" != "x"; then
- have_cl="yes"
- fi
-fi
-AM_CONDITIONAL(WITH_CL, [test "$have_cl" = "yes"])
-
AX_THRIFT_LIB(haxe, [Haxe], yes)
if test "$with_haxe" = "yes"; then
AC_PATH_PROG([HAXE], [haxe])
@@ -732,7 +721,6 @@ AC_CONFIG_FILES([
compiler/cpp/src/Makefile
compiler/cpp/test/Makefile
lib/Makefile
- lib/cl/Makefile
lib/cpp/Makefile
lib/cpp/test/Makefile
lib/cpp/thrift-nb.pc
@@ -780,7 +768,6 @@ AC_CONFIG_FILES([
test/Makefile
test/features/Makefile
test/c_glib/Makefile
- test/cl/Makefile
test/cpp/Makefile
test/erl/Makefile
test/go/Makefile
@@ -797,7 +784,6 @@ AC_CONFIG_FILES([
test/rs/Makefile
tutorial/Makefile
tutorial/c_glib/Makefile
- tutorial/cl/Makefile
tutorial/cpp/Makefile
tutorial/d/Makefile
tutorial/go/Makefile
@@ -852,8 +838,6 @@ if test "$have_swift" = "yes" ; then MAYBE_SWIFT="swift" ; else MAYBE_SWIFT="" ;
AC_SUBST([MAYBE_SWIFT])
if test "$have_netstd" = "yes" ; then MAYBE_NETSTD="netstd" ; else MAYBE_NETSTD="" ; fi
AC_SUBST([MAYBE_NETSTD])
-if test "$have_cl" = "yes" ; then MAYBE_CL="cl" ; else MAYBE_CL="" ; fi
-AC_SUBST([MAYBE_CL])
AC_OUTPUT
@@ -863,7 +847,6 @@ echo "$PACKAGE $VERSION"
echo
echo "Building C (GLib) Library .... : $have_c_glib"
echo "Building C++ Library ......... : $have_cpp"
-echo "Building Common Lisp Library.. : $have_cl"
echo "Building D Library ........... : $have_d"
echo "Building Dart Library ........ : $have_dart"
echo "Building .NET Standard Library : $have_netstd"
@@ -895,12 +878,6 @@ if test "$have_cpp" = "yes" ; then
echo " Build TQTcpServer (Qt5) ... : $have_qt5"
echo " C++ compiler version ...... : $($CXX --version | head -1)"
fi
-if test "$have_cl" = "yes" ; then
- echo
- echo "Common Lisp Library:"
- echo " Using Common Lisp ......... : $SBCL"
- echo " Using Common Lisp version . : $($SBCL --version)"
-fi
if test "$have_d" = "yes" ; then
echo
echo "D Library:"