summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJano Svitok <jsv@whitestein.com>2020-03-10 22:39:18 +0100
committerJens Geyer <jensg@apache.org>2020-03-13 02:17:58 +0100
commited1711e8611a2acc89b178a1cc0924b215e07a4c (patch)
tree1a9eed88096305d372583057420edb1a397e0c68 /configure.ac
parentadf278dae0b1e53baf100b6a7108327698545366 (diff)
downloadthrift-ed1711e8611a2acc89b178a1cc0924b215e07a4c.tar.gz
THRIFT-5087 test/test.py fails with "AssertionError: Python 3.3 or later is required for proper operation."
Client: Python Patch: Jano Svitok This closes #2055 THRIFT-5087: Show features log, check log presence THRIFT-5087: Revert/Improve PR1995 (commit f8b004081da) Make the condition work both a) when both python2 and python3 are installed b) when only python3 is installed Check also python 3.8 when searching for 3.x
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 99c3c9cd7..35f43ee5f 100755
--- a/configure.ac
+++ b/configure.ac
@@ -306,11 +306,15 @@ AM_CONDITIONAL(WITH_TWISTED_TEST, [test "$have_trial" = "yes"])
have_py3="no"
AX_THRIFT_LIB(py3, [Py3], yes)
if test "$with_py3" = "yes"; then
- if $PYTHON --version 2>&1 | grep -q "Python 3"; then
- AC_PATH_PROGS([PYTHON3], [python3 python3.7 python37 python3.6 python36 python3.5 python35 python3.4 python34])
+ # if $PYTHON is 2.x then search for python 3. otherwise, $PYTHON is already 3.x
+ if $PYTHON --version 2>&1 | grep -q "Python 2"; then
+ AC_PATH_PROGS([PYTHON3], [python3 python3.8 python38 python3.7 python37 python3.6 python36 python3.5 python35 python3.4 python34])
if test -n "$PYTHON3"; then
have_py3="yes"
fi
+ elif $PYTHON --version 2>&1 | grep -q "Python 3"; then
+ have_py3="yes"
+ PYTHON3=$PYTHON
fi
fi
AM_CONDITIONAL(WITH_PY3, [test "$have_py3" = "yes"])