summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJames E. King III <jking@apache.org>2019-05-04 08:20:59 -0400
committerJames E. King III <jking@apache.org>2019-05-04 21:52:29 -0400
commitee8caca54ef51e05c7eee8d67e3c63cd73081e8a (patch)
tree3de37789b240d96c1edd4dbf2bfca1fa3780cd9b /configure.ac
parent9ecdce3fe00931cebda39357b31b655236ab9221 (diff)
downloadthrift-ee8caca54ef51e05c7eee8d67e3c63cd73081e8a.tar.gz
THRIFT-4861: Set minimum boost to 1.56 and stop using deprecated boost predef endian header
Client: cpp
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b09c98361..5f25a5cf3 100755
--- a/configure.ac
+++ b/configure.ac
@@ -158,7 +158,7 @@ AM_CONDITIONAL(WITH_AS3, [test "$have_as3" = "yes"])
AX_THRIFT_LIB(cpp, [C++], yes)
have_cpp=no
if test "$with_cpp" = "yes"; then
- AX_BOOST_BASE([1.53.0])
+ AX_BOOST_BASE([1.56.0])
if test "x$succeeded" = "xyes" ; then
AC_SUBST([BOOST_LIB_DIR], [$(echo "$BOOST_LDFLAGS" | sed -e 's/^\-L//')])
AC_SUBST([BOOST_CHRONO_LDADD], [$(echo "$BOOST_LIB_DIR/libboost_chrono.a")])