summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNobuaki Sukegawa <nsuke@apache.org>2016-01-12 19:20:05 +0900
committerNobuaki Sukegawa <nsuke@apache.org>2016-01-19 02:48:07 +0900
commitffc2bb3dd7afc3214bddc0bcd656ea79f3ead427 (patch)
treef83ac433aa18f53b01c511a9c9218c87c2ca15fa /configure.ac
parentbaa110126d48b999dd4dff700e1f26559667487d (diff)
downloadthrift-ffc2bb3dd7afc3214bddc0bcd656ea79f3ead427.tar.gz
THRIFT-3439 Run make cross using Python3 when available
Client: Test Patch: Nobuaki Sukegawa Add Makefile.am change that was missing in the original patch. This closes #792
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac11
1 files changed, 5 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 3a1314d9c..92dc58ca7 100755
--- a/configure.ac
+++ b/configure.ac
@@ -274,10 +274,11 @@ if test "$with_lua" = "yes"; then
fi
AM_CONDITIONAL(WITH_LUA, [test "$have_lua" = "yes"])
+# Find python regardless of with_python value, because it's needed by make cross
+AM_PATH_PYTHON(2.6,, :)
AX_THRIFT_LIB(python, [Python], yes)
if test "$with_python" = "yes"; then
AC_PATH_PROG([TRIAL], [trial])
- AM_PATH_PYTHON(2.6,, :)
if test -n "$TRIAL" && test "x$PYTHON" != "x" && test "x$PYTHON" != "x:" ; then
have_python="yes"
fi
@@ -286,11 +287,9 @@ AM_CONDITIONAL(WITH_PYTHON, [test "$have_python" = "yes"])
# Find "python3" executable.
# It's distro specific and far from ideal but needed to cross test py2-3 at once.
-if test "x$have_python" = "xyes"; then
- AC_PATH_PROG([PYTHON3], [python3])
- if test "x$PYTHON3" != "x" && test "x$PYTHON3" != "x:" ; then
- have_py3="yes"
- fi
+AC_PATH_PROG([PYTHON3], [python3])
+if test "x$PYTHON3" != "x" && test "x$PYTHON3" != "x:" ; then
+ have_py3="yes"
fi
AM_CONDITIONAL(WITH_PY3, [test "$have_py3" = "yes"])