summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorDavid Reiss <dreiss@apache.org>2010-08-31 16:51:21 +0000
committerDavid Reiss <dreiss@apache.org>2010-08-31 16:51:21 +0000
commitea4c9816fc5c4a67e0804d7f1f5afbb1fc5d7c9a (patch)
tree1accf90f52f0bb0c9cdd0ada7b21f127b8dcf037 /lib/Makefile.am
parent5cc3ba83fd9c5563709f3c80a48f4820c82473f4 (diff)
downloadthrift-ea4c9816fc5c4a67e0804d7f1f5afbb1fc5d7c9a.tar.gz
THRIFT-506. Allow Thrift to be built without the C++ library
Currently, this is only possible by explicitly passing --without-cpp. It might be better to name it --without-cxx, but it is probably more important to keep consistency with the "cpp" generator and "lib/cpp". git-svn-id: https://svn.apache.org/repos/asf/incubator/thrift/trunk@991248 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index c949dc091..56c4e975d 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -17,8 +17,11 @@
# under the License.
#
-SUBDIRS = \
- cpp
+SUBDIRS =
+
+if WITH_CPP
+SUBDIRS += cpp
+endif
if WITH_MONO
SUBDIRS += csharp