summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authoralisdair sullivan <alisdairsullivan@yahoo.ca>2014-08-05 19:54:57 -0700
committerRoger Meier <roger@apache.org>2014-08-07 02:41:29 +0200
commit06d0fa05a56880ff341d8cc8f5de0ed47cf61c2c (patch)
treeaf8399b19f21a99a405660c3f29da9978ef0ec2f /test/Makefile.am
parenta0b86741169b8ef0a1e663154db447517bd89b0b (diff)
downloadthrift-06d0fa05a56880ff341d8cc8f5de0ed47cf61c2c.tar.gz
THRIFT-2648 cleanup erlang lib
client: erlang patch: alisdair sullivan (alisdairsullivan@yahoo.ca) moves tests for the thrift compiler generation of files to /test/erl, properly removes artifacts from test suite runs, adds module listing to .app.src for better behaviour when using erlang tools like relx and rebar and modifies .gitignore to not ignore relevant erlang test components
Diffstat (limited to 'test/Makefile.am')
-rwxr-xr-xtest/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index dddad1160..6f4bb0352 100755
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -49,6 +49,10 @@ if WITH_GO
SUBDIRS += go
endif
+if WITH_ERLANG
+SUBDIRS += erl
+endif
+
#
# generate html for ThriftTest.thrift
#
@@ -61,6 +65,7 @@ EXTRA_DIST = \
test.py \
tests.json \
cpp \
+ erl \
hs \
lua \
ocaml \