summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSebastian Zenker <sebastian.zenker@gmx.de>2019-01-31 02:14:27 +0100
committerJames E. King III <jking@apache.org>2019-01-30 20:14:27 -0500
commit2ec93c8a2da2531755078ab6d5a65a96e26cf4c2 (patch)
tree728151bc50149339c955d7258f6cb4b7bd59bcad /test/Makefile.am
parent4f7d93d8c35565fc9c5a43e4637505352c974c69 (diff)
downloadthrift-2ec93c8a2da2531755078ab6d5a65a96e26cf4c2.tar.gz
THRIFT-4763: HTML compiler produces invalid HTML document (#1720)
* HTML: the html generator did generate a closing </code> tag without a match <code> * THRIFT-4763: added HTML test and fixed up additional HTML generation issues
Diffstat (limited to 'test/Makefile.am')
-rwxr-xr-xtest/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 682e04a6e..f6b867cf1 100755
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -103,10 +103,17 @@ PRECROSS_TARGET += precross-rs
endif
#
-# generate html for ThriftTest.thrift
+# generate html for ThriftTest.thrift AND validate it!
#
+if WITH_NODEJS
check-local:
$(top_builddir)/compiler/cpp/thrift --gen html -r $(top_srcdir)/test/ThriftTest.thrift
+ $(top_builddir)/node_modules/.bin/html-validator --file=gen-html/index.html --verbose
+ $(top_builddir)/node_modules/.bin/html-validator --file=gen-html/ThriftTest.html --verbose
+else
+check-local:
+ $(top_builddir)/compiler/cpp/thrift --gen html -r $(top_srcdir)/test/ThriftTest.thrift
+endif
clean-local:
$(RM) -r $(top_srcdir)/test/gen-html/