summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorTomek Kurcz <tomsandbox@gmail.com>2017-09-19 09:16:43 +0200
committerJames E. King III <jking@apache.org>2018-03-02 13:44:50 -0500
commite93a90171529625966294fb35eaebf35cf4c6ba7 (patch)
tree287d2822c90c9d9e90c09fa00080c138f7aecfb1 /test/Makefile.am
parentd907cc92db5b93e699a4282e979d097ea863215a (diff)
downloadthrift-e93a90171529625966294fb35eaebf35cf4c6ba7.tar.gz
THRIFT-82: Add Common Lisp support
Client: cl There's framed and buffered socket transport, binary protocol, multiplex, simple server, cross-tests, self-tests, tutorial, CL library, CL code generator. Only SBCL is supported for now. This closes #1412
Diffstat (limited to 'test/Makefile.am')
-rwxr-xr-xtest/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 335bae63a..cb3d9aa64 100755
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -25,6 +25,11 @@ SUBDIRS += c_glib
PRECROSS_TARGET += precross-c_glib
endif
+if WITH_CL
+SUBDIRS += cl
+PRECROSS_TARGET += precross-cl
+endif
+
if WITH_MONO
SUBDIRS += csharp
PRECROSS_TARGET += precross-csharp
@@ -110,6 +115,7 @@ EXTRA_DIST = \
crossrunner \
keys \
c_glib \
+ cl \
cpp \
dart \
erl \