summaryrefslogtreecommitdiff
path: root/test/rb/Makefile.am
diff options
context:
space:
mode:
authorKevin Clark <kclark@apache.org>2008-07-08 00:47:49 +0000
committerKevin Clark <kclark@apache.org>2008-07-08 00:47:49 +0000
commit4bd8916b1257378f8173c4ada41b4606e9c0226b (patch)
treea43f051132e33d3ed07e3412b8777c3c08a75e6d /test/rb/Makefile.am
parentaf78778acd7fb551a84aaf63e604d969123bf85d (diff)
downloadthrift-4bd8916b1257378f8173c4ada41b4606e9c0226b.tar.gz
Merge branch 'fastbinary'
git-svn-id: https://svn.apache.org/repos/asf/incubator/thrift/trunk@674688 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'test/rb/Makefile.am')
-rw-r--r--test/rb/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/test/rb/Makefile.am b/test/rb/Makefile.am
new file mode 100644
index 000000000..b19fcde95
--- /dev/null
+++ b/test/rb/Makefile.am
@@ -0,0 +1,9 @@
+THRIFT = $(top_srcdir)/compiler/cpp/thrift
+
+stubs: ../ThriftTest.thrift ../SmallTest.thrift
+ $(THRIFT) --gen rb ../ThriftTest.thrift
+ $(THRIFT) --gen rb ../SmallTest.thrift
+
+check: stubs
+ $(RUBY) test_suite.rb
+