summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f0165f8f4..c77a6010c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,6 +47,9 @@ include(DefineInstallationPaths)
# Based on the options set some platform specifics
include(DefinePlatformSpecifc)
+# Add CMake targets for static code analysis
+include(StaticCodeAnalysis)
+
# Generate the config.h file
include(ConfigureChecks)
@@ -98,6 +101,9 @@ endif()
if(BUILD_C_GLIB)
add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/lib/c_glib)
+ if(BUILD_TESTING)
+ add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/test/c_glib)
+ endif()
endif()
if(BUILD_JAVA)