summaryrefslogtreecommitdiff
path: root/lib/go/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/go/test/Makefile.am')
-rw-r--r--lib/go/test/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/lib/go/test/Makefile.am b/lib/go/test/Makefile.am
index c255a8e48..cb8928bc8 100644
--- a/lib/go/test/Makefile.am
+++ b/lib/go/test/Makefile.am
@@ -62,7 +62,7 @@ gopath: $(THRIFT) $(THRIFTTEST) \
ProcessorMiddlewareTest.thrift \
ClientMiddlewareExceptionTest.thrift \
ValidateTest.thrift \
- ForwardTypedef.thrift
+ ForwardType.thrift
mkdir -p gopath/src
grep -v list.*map.*list.*map $(THRIFTTEST) | grep -v 'set<Insanity>' > ThriftTest.thrift
$(THRIFT) $(THRIFTARGS) -r IncludesTest.thrift
@@ -97,7 +97,7 @@ gopath: $(THRIFT) $(THRIFTTEST) \
$(THRIFT) $(THRIFTARGS_SKIP_REMOTE) ProcessorMiddlewareTest.thrift
$(THRIFT) $(THRIFTARGS) ClientMiddlewareExceptionTest.thrift
$(THRIFT) $(THRIFTARGS) ValidateTest.thrift
- $(THRIFT) $(THRIFTARGS) ForwardTypedef.thrift
+ $(THRIFT) $(THRIFTARGS) ForwardType.thrift
ln -nfs ../../tests gopath/src/tests
cp -r ./dontexportrwtest gopath/src
touch gopath
@@ -124,7 +124,7 @@ check: gopath
./gopath/src/processormiddlewaretest \
./gopath/src/clientmiddlewareexceptiontest \
./gopath/src/validatetest \
- ./gopath/src/forwardtypedef
+ ./gopath/src/forwardtypetest
$(GO) test github.com/apache/thrift/lib/go/thrift
$(GO) test ./gopath/src/tests ./gopath/src/dontexportrwtest
@@ -155,6 +155,7 @@ EXTRA_DIST = \
DuplicateImportsTest.thrift \
ErrorTest.thrift \
EqualsTest.thrift \
+ ForwardType.thrift \
GoTagTest.thrift \
IgnoreInitialismsTest.thrift \
IncludesTest.thrift \