summaryrefslogtreecommitdiff
path: root/lib/py/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'lib/py/setup.py')
-rw-r--r--lib/py/setup.py43
1 files changed, 43 insertions, 0 deletions
diff --git a/lib/py/setup.py b/lib/py/setup.py
new file mode 100644
index 000000000..748371156
--- /dev/null
+++ b/lib/py/setup.py
@@ -0,0 +1,43 @@
+#!/usr/bin/env python
+
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+from distutils.core import setup, Extension
+
+fastbinarymod = Extension('thrift.protocol.fastbinary',
+ sources = ['src/protocol/fastbinary.c'],
+ )
+
+setup(name = 'Thrift',
+ version = '1.0',
+ description = 'Thrift Python Libraries',
+ author = ['Mark Slee'],
+ author_email = ['mcslee@facebook.com'],
+ url = 'http://code.facebook.com/thrift',
+ packages = [
+ 'thrift',
+ 'thrift.protocol',
+ 'thrift.transport',
+ 'thrift.server',
+ ],
+ package_dir = {'thrift' : 'src'},
+ ext_modules = [fastbinarymod],
+ )
+