summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2015-04-29 11:11:30 -0400
committerSteve Dickson <steved@redhat.com>2015-04-29 17:05:33 -0400
commit4ba9ce277dd6c747e17d1e746c0b58b180bc0b11 (patch)
tree11b428e49970e967c1b4ec47a9b32885e407a4bb /Makefile.am
parent5d4970d31678ea208e92876a16dd03d1ac58d699 (diff)
downloadti-rpc-4ba9ce277dd6c747e17d1e746c0b58b180bc0b11.tar.gz
configure.ac: Allow for disabling auth DES
DES encryption might not be available. Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com> Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index aa270f6..2bf725c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,17 +28,21 @@ nobase_include_HEADERS = tirpc/netconfig.h \
tirpc/rpc/pmap_prot.h \
tirpc/rpc/pmap_clnt.h \
tirpc/rpc/nettype.h \
- tirpc/rpc/des.h \
- tirpc/rpc/des_crypt.h \
tirpc/rpc/clnt_stat.h \
tirpc/rpc/clnt_soc.h \
tirpc/rpc/clnt.h \
tirpc/rpc/auth_unix.h \
tirpc/rpc/auth_kerb.h \
tirpc/rpc/auth.h \
- tirpc/rpc/auth_gss.h \
+ tirpc/rpc/auth_gss.h
+
+if AUTHDES
+nobase_include_HEADERS += \
+ tirpc/rpc/des.h \
+ tirpc/rpc/des_crypt.h \
tirpc/rpc/auth_des.h
-
+endif
+
pkgconfigdir=$(libdir)/pkgconfig
pkgconfig_DATA = libtirpc.pc