summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChuck Lever <chuck.lever@oracle.com>2015-06-10 14:07:06 -0400
committerSteve Dickson <steved@redhat.com>2015-06-16 11:34:38 -0400
commitc261332cedc58f73c623d350bbce23e2de015af3 (patch)
tree8dfbb9164566666202ed30b0ab1491078cbc1e5d /Makefile.am
parentcc9148f915b745c0a4e3849f9576e0dfe8eae1b2 (diff)
downloadti-rpc-c261332cedc58f73c623d350bbce23e2de015af3.tar.gz
Revert commit 4ba9ce277dd6 ('configure.ac: Allow for disabling auth DES')
AUTH_DES is a part of legacy glibc SunRPC, and cannot be optional. Adding an autoconf macro (HAVE_AUTHDES) into libtirpc source files is OK, but adding such a macro into installed header files is wrong. Reported-by: Thorsten Kukuk <kukuk@suse.de> Signed-off-by: Chuck Lever <chuck.lever@oracle.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 3 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 466b6dd..13034e3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,10 +27,13 @@ nobase_include_HEADERS = tirpc/netconfig.h \
tirpc/rpc/pmap_prot.h \
tirpc/rpc/pmap_clnt.h \
tirpc/rpc/nettype.h \
+ tirpc/rpc/des.h \
+ tirpc/rpc/des_crypt.h \
tirpc/rpc/clnt_stat.h \
tirpc/rpc/clnt_soc.h \
tirpc/rpc/clnt.h \
tirpc/rpc/auth_unix.h \
+ tirpc/rpc/auth_des.h \
tirpc/rpc/auth_kerb.h \
tirpc/rpc/auth.h
@@ -41,13 +44,6 @@ nobase_include_HEADERS += \
tirpc/rpc/svc_auth_gss.h
endif
-if AUTHDES
-nobase_include_HEADERS += \
- tirpc/rpc/des.h \
- tirpc/rpc/des_crypt.h \
- tirpc/rpc/auth_des.h
-endif
-
pkgconfigdir=$(libdir)/pkgconfig
pkgconfig_DATA = libtirpc.pc