summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChuck Lever <chuck.lever@oracle.com>2015-06-01 08:00:50 -0400
committerSteve Dickson <steved@redhat.com>2015-06-01 08:11:35 -0400
commitda1cdd9c5953c0fb2c5659dbd31a19687420af1c (patch)
tree58ca3e414607058b7eea7789c0ccd9cc60bbcaac /Makefile.am
parent5f1fe4dde861f65142e5a0729aaabc4e9821737d (diff)
downloadti-rpc-da1cdd9c5953c0fb2c5659dbd31a19687420af1c.tar.gz
Expose legacy svcauth_gss APIs
svcauth_gss_set_svc_name() and svcauth_gss_get_principal() are part of the legacy U-M API that some RPC server applications may expect to be present. The trick is leaving these out when --disable-gssapi is specified. A new public header file is created to keep GSS-API dependencies separate. Reported-by: Thorsten Kukuk <kukuk@suse.de> Signed-off-by: Chuck Lever <chuck.lever@oracle.com> Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 59d0d7f..466b6dd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,7 +37,8 @@ nobase_include_HEADERS = tirpc/netconfig.h \
if GSS
nobase_include_HEADERS += \
tirpc/rpc/rpcsec_gss.h \
- tirpc/rpc/auth_gss.h
+ tirpc/rpc/auth_gss.h \
+ tirpc/rpc/svc_auth_gss.h
endif
if AUTHDES