summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSteve Dickson <steved@redhat.com>2007-04-20 14:56:09 -0400
committerSteve Dickson <steved@redhat.com>2007-04-20 14:56:09 -0400
commitee5471e0e4bcfab5b4da3faf46c96e5dbb49da47 (patch)
tree704fe6cab3d309429a2b39b1d35684ac953d943a /Makefile.am
downloadti-rpc-ee5471e0e4bcfab5b4da3faf46c96e5dbb49da47.tar.gz
Initial commit of libtirpc 0.1.7
Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..1a212e8
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,48 @@
+SUBDIRS = src
+
+nobase_include_HEADERS = tirpc/un-namespace.h \
+ tirpc/spinlock.h \
+ tirpc/reentrant.h \
+ tirpc/nss_tls.h \
+ tirpc/netconfig.h \
+ tirpc/namespace.h \
+ tirpc/libc_private.h \
+ tirpc/getpeereid.h \
+ tirpc/fpmath.h \
+ tirpc/rpcsvc/crypt.x \
+ tirpc/rpcsvc/crypt.h \
+ tirpc/misc/event.h \
+ tirpc/misc/socket.h \
+ tirpc/misc/queue.h \
+ tirpc/rpc/xdr.h \
+ tirpc/rpc/types.h \
+ tirpc/rpc/svc_soc.h \
+ tirpc/rpc/svc.h \
+ tirpc/rpc/svc_dg.h \
+ tirpc/rpc/svc_auth.h \
+ tirpc/rpc/rpc_msg.h \
+ tirpc/rpc/rpc.h \
+ tirpc/rpc/rpcent.h \
+ tirpc/rpc/rpc_com.h \
+ tirpc/rpc/rpcb_prot.x \
+ tirpc/rpc/rpcb_prot.h \
+ tirpc/rpc/rpcb_clnt.h \
+ tirpc/rpc/raw.h \
+ tirpc/rpc/pmap_rmt.h \
+ tirpc/rpc/pmap_prot.h \
+ tirpc/rpc/pmap_clnt.h \
+ tirpc/rpc/nettype.h \
+ tirpc/rpc/des.h \
+ tirpc/rpc/des_crypt.h \
+ tirpc/rpc/clnt_stat.h \
+ tirpc/rpc/clnt_soc.h \
+ tirpc/rpc/clnt.h \
+ tirpc/rpc/auth_unix.h \
+ tirpc/rpc/auth_kerb.h \
+ tirpc/rpc/auth.h \
+ tirpc/rpc/auth_gss.h \
+ tirpc/rpc/auth_des.h
+
+install-exec-local:
+ cp -p ./doc/etc_netconfig /etc/netconfig
+ chmod 0644 /etc/netconfig