summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChuck Lever <chuck.lever@oracle.com>2015-06-01 07:45:17 -0400
committerSteve Dickson <steved@redhat.com>2015-06-01 08:11:35 -0400
commit29d48e0879edf6d9d636b1d6fff89863714c3331 (patch)
treedb3cd3c5d8f47005358f434e58b0adfe3d98c799 /configure.ac
parented27a11118af452f6e97b0a5e0bd387fc9b23bd5 (diff)
downloadti-rpc-29d48e0879edf6d9d636b1d6fff89863714c3331.tar.gz
"configure --enable-gssapi" should fail if gssapi.h not found
"configure --enable-gssapi" on a system without GSS-API installed completes normally. Then "make" fails with: CC libtirpc_la-bindresvport.lo In file included from ../tirpc/rpc/rpc.h:64:0, from bindresvport.c:46: ../tirpc/rpc/auth_gss.h:41:27: fatal error: gssapi/gssapi.h: No such file or directory #include <gssapi/gssapi.h> ^ compilation terminated. Makefile:604: recipe for target 'libtirpc_la-bindresvport.lo' failed Since gssapi.h is a requirement when --enable-gssapi is specified, make ./configure fail if gssapi.h is not installed. Signed-off-by: Chuck Lever <chuck.lever@oracle.com> Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f2965a0..f46daf7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,6 +3,9 @@ AM_INIT_AUTOMAKE([silent-rules])
AM_SILENT_RULES([yes])
AC_CONFIG_SRCDIR([src/auth_des.c])
AC_CONFIG_MACRO_DIR([m4])
+AC_PROG_CC
+
+AC_CHECK_HEADER([gssapi/gssapi.h], [HAVE_GSSAPI_H=yes], [HAVE_GSSAPI_H=no])
AC_ARG_ENABLE(gssapi,
[AC_HELP_STRING([--disable-gssapi], [Disable GSSAPI support @<:@default=no@:>@])],
@@ -10,6 +13,9 @@ AC_ARG_ENABLE(gssapi,
AM_CONDITIONAL(GSS, test "x$enable_gssapi" = xyes)
if test "x$enable_gssapi" = xyes; then
+ if test "x$HAVE_GSSAPI_H" = xno; then
+ AC_MSG_ERROR([gssapi.h not found. Use --disable-gssapi, or install GSS-API.])
+ fi
AC_CHECK_TOOL([KRB5_CONFIG], [krb5-config], [no])
if test "x$KRB5_CONFIG" = xno; then
AC_MSG_ERROR([krb5-config tool not found. Use --disable-gssapi, or install Kerberos.])
@@ -44,7 +50,6 @@ AC_ARG_ENABLE(symvers,
[],[enable_symvers=yes])
AM_CONDITIONAL(SYMVERS, test "x$enable_symvers" = xyes)
-AC_PROG_CC
AC_CONFIG_HEADERS([config.h])
AC_PROG_LIBTOOL
AC_HEADER_DIRENT