summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChuck Lever <chuck.lever@oracle.com>2015-06-10 11:17:12 -0400
committerSteve Dickson <steved@redhat.com>2015-06-16 11:34:38 -0400
commit40181dc28848b7afd7941f5991f0b8b5bac4771c (patch)
tree97eadf095db218229e2cfd18cac41c354dca4922 /configure.ac
parent9f50219229c1f2de9c0c597fa085dc8cc313c339 (diff)
downloadti-rpc-40181dc28848b7afd7941f5991f0b8b5bac4771c.tar.gz
Revert commit cf29aa829f80 ('configure.ac: Disable DES auth by default')
AUTH_DES is provided in older glibc versions and is therefore required for backward compatibility. Some applications still require at least rpc/auth_des.h to be present. Thus, though it is deprecated, it is not an optional part of the SunRPC legacy API. Reported-by: Thorsten Kukuk <kukuk@suse.de> Signed-off-by: Chuck Lever <chuck.lever@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6e7b068..0846b59 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,8 +27,8 @@ if test "x$enable_gssapi" = xyes; then
fi
AC_ARG_ENABLE(authdes,
- [AC_HELP_STRING([--enable-authdes], [Enable DES authentication @<:@default=no@:>@])],
- [],[enable_authdes=no])
+ [AC_HELP_STRING([--disable-authdes], [Disable DES authentication @<:@default=no@:>@])],
+ [],[enable_authdes=yes])
AM_CONDITIONAL(AUTHDES, test "x$enable_authdes" = xyes)
if test "x$enable_authdes" = xyes; then
AC_DEFINE([HAVE_AUTHDES], [1],