summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-11-13 15:37:15 -0500
committerSteve Dickson <steved@redhat.com>2012-11-13 15:37:15 -0500
commit5d38387335e2b7c5055be0d51fad579930388574 (patch)
treec3fb9cd7e21d4a43243c0714dcca33dd717ae7be /configure.ac
parentdb3682d99b9d17c745a6286b404abf2f4d1347a2 (diff)
downloadti-rpc-5d38387335e2b7c5055be0d51fad579930388574.tar.gz
Make IPv6 enabled by default
Added a --disable-ipv6 configuration flag to allow the disabling of the IPv6 support. Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7ff80a4..a99c5d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,6 +15,13 @@ if test x$gss = xtrue; then
PKG_CHECK_MODULES(GSSGLUE, libgssglue, [],
AC_MSG_ERROR([Unable to locate information required to use libgssglue.]))
fi
+AC_ARG_ENABLE(ipv6,
+ [AC_HELP_STRING([--disable-ipv6], [Disable IPv6 support @<:@default=no@:>@])],
+ [],[enable_ipv6=yes])
+AM_CONDITIONAL(INET6, test "x$disable_ipv6" != xno)
+if test "x$enable_ipv6" != xno; then
+ AC_DEFINE(INET6, 1, [Define to 1 if IPv6 is available])
+fi
AC_PROG_CC
AM_CONFIG_HEADER(config.h)