summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@suse.de>2015-05-07 16:14:04 -0400
committerSteve Dickson <steved@redhat.com>2015-05-07 23:31:01 -0400
commit7b7337b7e6541649a82b09a5c268c7fe6404fbf4 (patch)
tree02006bf10ac1ae8d425da13b68afc2fbdac8d5f6 /configure.ac
parent9a7748e8e02ce5f91869879387f1829232bd3dd7 (diff)
downloadti-rpc-7b7337b7e6541649a82b09a5c268c7fe6404fbf4.tar.gz
Fix Build w/gssapi disabled
A regression was introduced by commit d5259e75 that broke the --disable-gssapi configuration flag causing numerous compile errors. This patch fixes those errors but then the config flag is used it breaks API with previous releases. Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 711b054..290c635 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,6 +10,7 @@ AC_ARG_ENABLE(gssapi,
AM_CONDITIONAL(GSS, test "x$enable_gssapi" = xyes)
if test "x$enable_gssapi" = xyes; then
+ AC_DEFINE([HAVE_GSSAPI], [1], [Define to 1 if GSSAPI is enabled])
GSSAPI_CFLAGS=`krb5-config --cflags gssapi`
GSSAPI_LIBS=`krb5-config --libs gssapi`
AC_SUBST([GSSAPI_CFLAGS])
@@ -41,7 +42,7 @@ AC_ARG_ENABLE(symvers,
AM_CONDITIONAL(SYMVERS, test "x$enable_symvers" = xyes)
AC_PROG_CC
-AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_HEADERS([config.h tirpc/tirpc-features.h])
AC_PROG_LIBTOOL
AC_HEADER_DIRENT
AC_PREFIX_DEFAULT(/usr)