summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSteve Dickson <steved@redhat.com>2009-07-09 15:53:08 -0400
committerSteve Dickson <steved@redhat.com>2009-07-09 15:53:08 -0400
commit8717a2cff3ad6a4023b45864912987d831cd5f0b (patch)
tree61efd0b8cfe02bd70eb57d09bc5b2b8a6751e109 /configure.ac
parent5851af9f3362bd3ffd742d6e4a1eb87002a18dfc (diff)
downloadti-rpc-8717a2cff3ad6a4023b45864912987d831cd5f0b.tar.gz
Added HAVE_LIBGSSAPI defines around gss codelibtirpc-0-2-1-rc3
so the --disble-gss configure option would work Renamed configure.in to configure.ac so the HAVE_LIBGSSAPI define would be defined in the correct place. Clean up warnings when --enable-gss is used. Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 29 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..df50e94
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,29 @@
+AC_INIT(libtirpc, 0.2.0)
+AM_INIT_AUTOMAKE(libtirpc, 0.2.0)
+AM_MAINTAINER_MODE
+AC_CONFIG_SRCDIR([src/auth_des.c])
+
+AC_ARG_ENABLE(gss,[ --enable-gss Turn on gss api], [case "${enableval}" in
+ yes) gss=true ; AC_CHECK_LIB([gssapi],[gss_init_sec_context]) ;;
+ no) gss=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-gss) ;;
+ esac],[gss=false])
+AM_CONDITIONAL(GSS, test x$gss = xtrue)
+if test x$gss = xtrue; then
+ AC_DEFINE(HAVE_LIBGSSAPI, 1, [])
+ PKG_CHECK_MODULES(GSSGLUE, libgssglue, [],
+ AC_MSG_ERROR([Unable to locate information required to use libgssglue.]))
+fi
+
+AC_PROG_CC
+AM_CONFIG_HEADER(config.h)
+AC_PROG_LIBTOOL
+##AC_PROG_RANLIB
+AC_HEADER_DIRENT
+AC_PREFIX_DEFAULT(/usr)
+AC_CHECK_HEADERS([arpa/inet.h fcntl.h libintl.h limits.h locale.h netdb.h netinet/in.h stddef.h stdint.h stdlib.h string.h sys/ioctl.h sys/param.h sys/socket.h sys/time.h syslog.h unistd.h])
+AC_CHECK_LIB([pthread], [pthread_create])
+
+
+AC_CONFIG_FILES([Makefile src/Makefile man/Makefile doc/Makefile])
+AC_OUTPUT(libtirpc.pc)