summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSteve Dickson <steved@redhat.com>2013-12-09 14:57:13 -0500
committerSteve Dickson <steved@redhat.com>2013-12-09 15:34:56 -0500
commitb5209d95d362b4c66184463ec14b2d8a6f3bcd0b (patch)
tree9b1b350850c0e69b8c087b2d51a438dcf8b1e04a /configure.ac
parent07885a8cd789e6d9171df367c6218ac264408989 (diff)
downloadti-rpc-b5209d95d362b4c66184463ec14b2d8a6f3bcd0b.tar.gz
configure.ac: Remove gssglue configuration knobs
Its really not a good idea for libtirpc to link with libgssglue so this patch remove the ability to do that. Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 4 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index b9906dc..6b0cf27 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,26 +10,11 @@ AC_ARG_ENABLE(gssapi,
[],[enable_gssapi=yes])
AM_CONDITIONAL(GSS, test x$enable_gssapi = xyes)
-AC_ARG_WITH(gssglue,
- [ --with-gssglue Use libgssglue],
- [case "${enableval}" in
- yes) gssglue=true ;;
- no) gssglue=false ;;
- *) AC_MSG_ERROR(bad value ${enableval} for --with-gssglue) ;;
- esac],
- [gssglue=false])
-AM_CONDITIONAL(USEGSSGLUE, test x$gssglue = xtrue)
-
if test x$enable_gssapi = xyes; then
- if test x$gssglue = xtrue; then
- PKG_CHECK_MODULES(GSSAPI, libgssglue, [],
- AC_MSG_ERROR([Unable to locate information required to use libgssglue.]))
- else
- GSSAPI_CFLAGS=`krb5-config --cflags gssapi`
- GSSAPI_LIBS=`krb5-config --libs gssapi`
- AC_SUBST([GSSAPI_CFLAGS])
- AC_SUBST([GSSAPI_LIBS])
- fi
+ GSSAPI_CFLAGS=`krb5-config --cflags gssapi`
+ GSSAPI_LIBS=`krb5-config --libs gssapi`
+ AC_SUBST([GSSAPI_CFLAGS])
+ AC_SUBST([GSSAPI_LIBS])
fi
AC_ARG_ENABLE(ipv6,
[AC_HELP_STRING([--disable-ipv6], [Disable IPv6 support @<:@default=no@:>@])],