summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-04-22 12:23:57 -0400
committerSteve Dickson <steved@redhat.com>2015-04-23 08:29:45 -0400
commitc0547c56dafb8e1cb4d2780df89b39a45085ad2f (patch)
treeeb0457ffad13f5f8f9e36fa7469e9fdd05994b6d /configure.ac
parent489912cad88ff5e13477ae2f19baa93415c981db (diff)
downloadti-rpc-c0547c56dafb8e1cb4d2780df89b39a45085ad2f.tar.gz
Add configure option to disable DES authentication
DES is not good for encryption anymore and some C libraries does not even implement it. We add a --disable-authdes to optionally disable it, but let it be enabled by default for compatibility. This is needed for musl libc. Signed-off-by: Natanael Copa <ncopa@alpinelinux.org> Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0180801..e6d3df5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,6 +15,12 @@ if test x$enable_gssapi = xyes; then
AC_SUBST([GSSAPI_CFLAGS])
AC_SUBST([GSSAPI_LIBS])
fi
+
+AC_ARG_ENABLE(authdes,
+ [AC_HELP_STRING([--disable-authdes], [Disable DES authentication @<:@default=no@:>@])],
+ [],[enable_authdes=yes])
+AM_CONDITIONAL(AUTHDES, test x$enable_authdes = xyes)
+
AC_ARG_ENABLE(ipv6,
[AC_HELP_STRING([--disable-ipv6], [Disable IPv6 support @<:@default=no@:>@])],
[],[enable_ipv6=yes])