summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@suse.de>2015-05-06 09:53:28 -0400
committerSteve Dickson <steved@redhat.com>2015-05-06 10:03:35 -0400
commitcb6163a301650d6bd1fd88e739826715fe8e9c34 (patch)
treeb3d321812d6b8b7bbc8c13e049f3f3c2680b564a /configure.ac
parent58cd17f99974dcb6ae4654a4fc0de525585d2470 (diff)
downloadti-rpc-cb6163a301650d6bd1fd88e739826715fe8e9c34.tar.gz
Symbol versioning patchlibtirpc-0-2-6-rc5
Added the functions, which are not marked static and for which we provide a protoype in the public installed header files. Additional, there is the function __libc_clntudp_bufcreate for glibc compatibility and the three functions: __svc_clean_idle; svc_auth_none; libtirpc_set_debug used by rpcbind. I have added them as "TIRPC_PRIVATE". If we want to provide them as official functions for everybody, we should add prototypes to the header files and move them to the TIRPC_0.3.0 section. Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 9 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 7be0b91..0216c21 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,9 +7,9 @@ AC_CONFIG_MACRO_DIR([m4])
AC_ARG_ENABLE(gssapi,
[AC_HELP_STRING([--disable-gssapi], [Disable GSSAPI support @<:@default=no@:>@])],
[],[enable_gssapi=yes])
-AM_CONDITIONAL(GSS, test x$enable_gssapi = xyes)
+AM_CONDITIONAL(GSS, test "x$enable_gssapi" = xyes)
-if test x$enable_gssapi = xyes; then
+if test "x$enable_gssapi" = xyes; then
GSSAPI_CFLAGS=`krb5-config --cflags gssapi`
GSSAPI_LIBS=`krb5-config --libs gssapi`
AC_SUBST([GSSAPI_CFLAGS])
@@ -19,8 +19,8 @@ fi
AC_ARG_ENABLE(authdes,
[AC_HELP_STRING([--enable-authdes], [Enable DES authentication @<:@default=no@:>@])],
[],[enable_authdes=no])
-AM_CONDITIONAL(AUTHDES, test x$enable_authdes = xyes)
-if test x$enable_authdes = xyes; then
+AM_CONDITIONAL(AUTHDES, test "x$enable_authdes" = xyes)
+if test "x$enable_authdes" = xyes; then
AC_DEFINE([HAVE_AUTHDES], [1],
[Define to 1 if DES authentication is enabled])
CFLAG_AUTHDES="-DHAVE_AUTHDES=1"
@@ -35,6 +35,11 @@ if test "x$enable_ipv6" != xno; then
AC_DEFINE(INET6, 1, [Define to 1 if IPv6 is available])
fi
+AC_ARG_ENABLE(symvers,
+ [AC_HELP_STRING([--disable-symvers], [Disable symbol versioning @<:@default=no@:>@])],
+ [],[enable_symvers=yes])
+AM_CONDITIONAL(SYMVERS, test "x$enable_symvers" = xyes)
+
AC_PROG_CC
AC_CONFIG_HEADERS([config.h])
AC_PROG_LIBTOOL