summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorArmin K <krejzi@email.com>2015-06-26 14:25:27 -0400
committerSteve Dickson <steved@redhat.com>2015-06-26 14:25:27 -0400
commit73fa76516e8746d47a07b8efddaf1b4e08ae8611 (patch)
treedb9d4a1d7f89ca4d5b073da1809ac571723f6aa3 /src/Makefile.am
parent229455848ab703603787b1881595e4bd05bc40c4 (diff)
downloadti-rpc-73fa76516e8746d47a07b8efddaf1b4e08ae8611.tar.gz
Makefile.am: Add -Wl,-no-undefined
Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 66fcc6c..18b1cec 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -41,7 +41,7 @@ lib_LTLIBRARIES = libtirpc.la
# release number of your package. This is an abuse that only fosters
# misunderstanding of the purpose of library versions."
#
-libtirpc_la_LDFLAGS = -lpthread -version-info 1:10:0
+libtirpc_la_LDFLAGS = -Wl,-no-undefined -lpthread -version-info 1:10:0
libtirpc_la_SOURCES = auth_none.c auth_unix.c authunix_prot.c bindresvport.c clnt_bcast.c \
clnt_dg.c clnt_generic.c clnt_perror.c clnt_raw.c clnt_simple.c \