summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2013-03-26 11:13:05 -0400
committerSteve Dickson <steved@redhat.com>2013-03-26 11:13:05 -0400
commit9151a39539145e1f62f8b30168d1cdeb19299dac (patch)
tree68bebdfb86d0ef4a4858a8d45ea21a232d976ac8 /src/Makefile.am
parent7cc9136dc6b28ba507af8781e3408233a6462b42 (diff)
downloadti-rpc-9151a39539145e1f62f8b30168d1cdeb19299dac.tar.gz
Switch to use standard GSSAPI by default
Make libgssglue configurable still but disabled by default. There is no reason to use libgssglue anymore, and modern gssapi supports all needed features for libtirpc and its dependencies. Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 66350f5..2dd7768 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -58,8 +58,8 @@ libtirpc_la_SOURCES += xdr.c xdr_rec.c xdr_array.c xdr_float.c xdr_mem.c xdr_ref
## Secure-RPC
if GSS
libtirpc_la_SOURCES += auth_gss.c authgss_prot.c svc_auth_gss.c
- libtirpc_la_LDFLAGS += $(GSSGLUE_LIBS)
- libtirpc_la_CFLAGS = -DHAVE_RPCSEC_GSS $(GSSGLUE_CFLAGS)
+ libtirpc_la_LDFLAGS += $(GSSAPI_LIBS)
+ libtirpc_la_CFLAGS = -DHAVE_RPCSEC_GSS $(GSSAPI_CFLAGS)
endif
## libtirpc_a_SOURCES += key_call.c key_prot_xdr.c getpublickey.c