summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSteve Dickson <steved@redhat.com>2007-10-25 13:38:31 -0400
committerSteve Dickson <steved@redhat.com>2007-10-25 13:38:31 -0400
commitb38779476347002800674a441ea3fb24a4aa1edc (patch)
treed223f775237a1ced1bcc0a6f0f72b86770822fa0 /src/Makefile.am
parentb5a64db41f0f49929dea8268a67820fa6a5ae053 (diff)
downloadti-rpc-b38779476347002800674a441ea3fb24a4aa1edc.tar.gz
When the configuration --enable-gss used, the libgssglue
library will be used instead of the libgssapi. Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f3f9625..79bec0b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -28,10 +28,9 @@ libtirpc_la_SOURCES += xdr.c xdr_rec.c xdr_array.c xdr_float.c xdr_mem.c xdr_ref
## Secure-RPC
if GSS
- libtirpc_la_SOURCES += auth_gss.c authgss_prot.c svc_auth_gss.c \
- svc_auth_none.c
- libtirpc_la_LDFLAGS += $(GSSAPI_LIBS)
- libtirpc_la_CFLAGS = -DHAVE_RPCSEC_GSS $(GSSAPI_CFLAGS)
+ libtirpc_la_SOURCES += auth_gss.c authgss_prot.c svc_auth_gss.c
+ libtirpc_la_LDFLAGS += $(GSSGLUE_LIBS)
+ libtirpc_la_CFLAGS = -DHAVE_RPCSEC_GSS $(GSSGLUE_CFLAGS)
endif
## libtirpc_a_SOURCES += key_call.c key_prot_xdr.c getpublickey.c
@@ -50,7 +49,7 @@ $(libtirpc_la_OBJECTS) :auth_none.c auth_unix.c authunix_prot.c bindresvport.c c
svc_raw.c svc_run.c svc_simple.c svc_vc.c \
xdr.c xdr_rec.c xdr_array.c xdr_float.c xdr_mem.c xdr_reference.c xdr_stdio.c \
auth_gss.c authgss_prot.c svc_auth_gss.c getpeereid.c \
- auth_time.c auth_des.c authdes_prot.c svc_auth_none.c
+ auth_time.c auth_des.c authdes_prot.c
else
$(libtirpc_la_OBJECTS) :auth_none.c auth_unix.c authunix_prot.c bindresvport.c clnt_bcast.c \