summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorNick Alcock <nick.alcock@oracle.com>2012-04-26 15:38:56 -0400
committerSteve Dickson <steved@redhat.com>2012-04-26 15:54:02 -0400
commitea965b0b4cd592527558f01cb254629b6ecbb50f (patch)
tree1f30388b2d13850140a18ca244cddcd7dfbf9da4 /src/Makefile.am
parentdda745c63d3c0744b3937cf01f3ec9c9690998fa (diff)
downloadti-rpc-ea965b0b4cd592527558f01cb254629b6ecbb50f.tar.gz
No longer require NIS.
From: Nick Alcock <nick.alcock@oracle.com> NIS is deader than the proverbial dodo, and eglibc allows you to compile it out entirely. Though libtirpc can work with NIS, it works perfectly well if NIS is not in the libc, thanks to nsswitch (acting as if NIS is there but empty). However, when NIS is not compiled into eglibc, libnsl is not present. So check for it at configure time, and include it via LIBS if available. (I suspect this LIBS-inclusion will have no effect, and we don't even need to check for NIS at compile time, but I have no NIS-capable systems to test this on.) Signed-off-by: Nick Alcock <nick.alcock@oracle.com> Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 509cf61..66350f5 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -40,7 +40,7 @@ lib_LTLIBRARIES = libtirpc.la
# release number of your package. This is an abuse that only fosters
# misunderstanding of the purpose of library versions."
#
-libtirpc_la_LDFLAGS = -lnsl -lpthread -version-info 1:10:0
+libtirpc_la_LDFLAGS = -lpthread -version-info 1:10:0
libtirpc_la_SOURCES = auth_none.c auth_unix.c authunix_prot.c bindresvport.c clnt_bcast.c \
clnt_dg.c clnt_generic.c clnt_perror.c clnt_raw.c clnt_simple.c \