summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMonty <xiphmont@xiph.org>2009-07-11 10:03:10 +0000
committerMonty <xiphmont@xiph.org>2009-07-11 10:03:10 +0000
commit4ce4ec7859e7f8074341cfb00af1c207f5d24d3f (patch)
tree90bbcd709f76579ee1da1702f1a39db1c9299d4d /Makefile.am
parentafdecda7fe28e347380e98ca66a00cbbee4cd9f3 (diff)
downloadtremor-4ce4ec7859e7f8074341cfb00af1c207f5d24d3f.tar.gz
Merge recent vorbifile changes, extensions and fixes back from
reference 1.2.2 and 1.2.3 into tremor. git-svn-id: https://svn.xiph.org/trunk/Tremor@16259 0101bb08-14d6-0310-b084-bc0e0c8e3800
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d14081f..72fc521 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,13 +16,17 @@ libvorbisidec_la_SOURCES = mdct.c block.c window.c \
asm_arm.h ivorbiscodec.h
libvorbisidec_la_LDFLAGS = -version-info @V_LIB_CURRENT@:@V_LIB_REVISION@:@V_LIB_AGE@
-EXTRA_PROGRAMS = ivorbisfile_example
+EXTRA_PROGRAMS = ivorbisfile_example iseeking_example
CLEANFILES = $(EXTRA_PROGRAMS) $(lib_LTLIBRARIES)
ivorbisfile_example_SOURCES = ivorbisfile_example.c
ivorbisfile_example_LDFLAGS = -static
ivorbisfile_example_LDADD = libvorbisidec.la
+iseeking_example_SOURCES = iseeking_example.c
+iseeking_example_LDFLAGS = -static
+iseeking_example_LDADD = libvorbisidec.la
+
includedir = $(prefix)/include/tremor
include_HEADERS = ivorbiscodec.h ivorbisfile.h ogg.h os_types.h config_types.h
@@ -30,6 +34,7 @@ include_HEADERS = ivorbiscodec.h ivorbisfile.h ogg.h os_types.h config_types.h
example:
-ln -fs . vorbis
$(MAKE) ivorbisfile_example
+ $(MAKE) iseeking_example
debug:
$(MAKE) all CFLAGS="@DEBUG@"