summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTim Terriberry <tterribe@xiph.org>2010-08-31 19:10:31 +0000
committerTim Terriberry <tterribe@xiph.org>2010-08-31 19:10:31 +0000
commit8886a2805fc107489912f8c500db3373e04a316d (patch)
tree42854e1ade8a2b627c52f2482bf27793054c0523 /Makefile.am
parent7125eb6381e57436db1c5a2d7c4e52091c37e95c (diff)
downloadtremor-8886a2805fc107489912f8c500db3373e04a316d.tar.gz
Convert Tremor to use libogg instead of its own internal libogg2.
This makes it easier to use Tremor as a drop-in replacement for libvorbis and reduces code size and overhead for those who don't want to use its built-in Ogg demuxer. This commit also backports all of the changes that have accumulated in libvorbis's vorbisfile implementation, with the exception of halfrate decoding and cross-lapped seeking. Those should not be too hard to add if someone really wants them. git-svn-id: https://svn.xiph.org/trunk/Tremor@17375 0101bb08-14d6-0310-b084-bc0e0c8e3800
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index dad89a5..0a4bb2c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
AUTOMAKE_OPTIONS = foreign
-INCLUDES = -I./
+INCLUDES = -I./ @OGG_CFLAGS@
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = vorbisidec.pc
@@ -11,28 +11,29 @@ libvorbisidec_la_SOURCES = mdct.c block.c window.c \
synthesis.c info.c \
floor1.c floor0.c vorbisfile.c \
res012.c mapping0.c registry.c codebook.c \
- sharedbook.c framing.c bitwise.c \
+ sharedbook.c \
codebook.h misc.h mdct_lookup.h\
os.h mdct.h block.h ivorbisfile.h lsp_lookup.h\
registry.h window.h window_lookup.h\
- codec_internal.h backends.h ogg.h \
+ codec_internal.h backends.h \
asm_arm.h ivorbiscodec.h
libvorbisidec_la_LDFLAGS = -version-info @V_LIB_CURRENT@:@V_LIB_REVISION@:@V_LIB_AGE@
+libvorbisidec_la_LIBADD = @OGG_LIBS@
EXTRA_PROGRAMS = ivorbisfile_example iseeking_example
CLEANFILES = $(EXTRA_PROGRAMS) $(lib_LTLIBRARIES)
ivorbisfile_example_SOURCES = ivorbisfile_example.c
ivorbisfile_example_LDFLAGS = -static
-ivorbisfile_example_LDADD = libvorbisidec.la
+ivorbisfile_example_LDADD = libvorbisidec.la @OGG_LIBS@
iseeking_example_SOURCES = iseeking_example.c
iseeking_example_LDFLAGS = -static
-iseeking_example_LDADD = libvorbisidec.la
+iseeking_example_LDADD = libvorbisidec.la @OGG_LIBS@
includedir = $(prefix)/include/tremor
-include_HEADERS = ivorbiscodec.h ivorbisfile.h ogg.h os_types.h config_types.h
+include_HEADERS = ivorbiscodec.h ivorbisfile.h config_types.h
EXTRA_DIST = vorbisidec.pc.in \
$(srcdir)/doc/*.html $(srcdir)/win32/VS*/libtremor/*.vcproj