summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMonty <xiphmont@xiph.org>2002-09-03 01:48:59 +0000
committerMonty <xiphmont@xiph.org>2002-09-03 01:48:59 +0000
commit0011ccf3eb4141c5c1e86dbeed94565246615b6f (patch)
treeb8ff7b5bdaba2578e117eaad0cff8c102633f65b /configure.in
parentab36cd2c102181291a51a834d5dc3ace0c520b50 (diff)
downloadtremor-0011ccf3eb4141c5c1e86dbeed94565246615b6f.tar.gz
add configure.in
git-svn-id: https://svn.xiph.org/trunk/Tremor@3893 0101bb08-14d6-0310-b084-bc0e0c8e3800
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in99
1 files changed, 99 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..ec9b62b
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,99 @@
+dnl Process this file with autoconf to produce a configure script
+
+dnl ------------------------------------------------
+dnl Initialization and Versioning
+dnl ------------------------------------------------
+
+AC_INIT(mdct.c)
+AM_INIT_AUTOMAKE(libvorbisidec,1.0.2)
+
+dnl Library versioning
+
+V_LIB_CURRENT=1
+V_LIB_REVISION=0
+V_LIB_AGE=2
+AC_SUBST(V_LIB_CURRENT)
+AC_SUBST(V_LIB_REVISION)
+AC_SUBST(V_LIB_AGE)
+
+dnl --------------------------------------------------
+dnl Check for programs
+dnl --------------------------------------------------
+
+dnl save $CFLAGS since AC_PROG_CC likes to insert "-g -O2"
+dnl if $CFLAGS is blank
+cflags_save="$CFLAGS"
+AC_PROG_CC
+AC_PROG_CPP
+CFLAGS="$cflags_save"
+
+AM_PROG_LIBTOOL
+
+dnl --------------------------------------------------
+dnl Set build flags based on environment
+dnl --------------------------------------------------
+
+AC_CANONICAL_HOST
+
+dnl Set some target options
+
+cflags_save="$CFLAGS"
+ldflags_save="$LDFLAGS"
+if test -z "$GCC"; then
+ case $host in
+ arm-*-*)
+ DEBUG="-g -D_ARM_ASSEM_"
+ CFLAGS="-O -D_ARM_ASSEM_"
+ PROFILE="-p -g -O -D_ARM_ASSEM" ;;
+ *)
+ DEBUG="-g"
+ CFLAGS="-O"
+ PROFILE="-g -p" ;;
+ esac
+else
+
+ case $host in
+ arm-*-*)
+ DEBUG="-g -W -D__NO_MATH_INLINES -fsigned-char -D_ARM_ASSEM_"
+ CFLAGS="-O2 -D_ARM_ASSEM_ -fsigned-char"
+ PROFILE="-W -pg -g -O2 -D_ARM_ASSEM_ -fsigned-char -fno-inline-functions";;
+
+ *)
+ DEBUG="-g -W -D__NO_MATH_INLINES -fsigned-char"
+ CFLAGS="-O2 -fsigned-char"
+ PROFILE="-W -pg -g -O2 -fsigned-char -fno-inline-functions";;
+ esac
+fi
+CFLAGS="$CFLAGS $cflags_save -D_REENTRANT"
+LDFLAGS="$LDFLAGS $ldflags_save"
+
+dnl --------------------------------------------------
+dnl Check for headers
+dnl --------------------------------------------------
+
+AC_CHECK_HEADER(memory.h,CFLAGS="$CFLAGS -DUSE_MEMORY_H",:)
+
+dnl --------------------------------------------------
+dnl Check for typedefs, structures, etc
+dnl --------------------------------------------------
+
+dnl none
+
+dnl --------------------------------------------------
+dnl Check for library functions
+dnl --------------------------------------------------
+
+AC_FUNC_ALLOCA
+AC_FUNC_MEMCMP
+
+dnl --------------------------------------------------
+dnl Do substitutions
+dnl --------------------------------------------------
+
+LIBS="$LIBS"
+
+AC_SUBST(LIBS)
+AC_SUBST(DEBUG)
+AC_SUBST(PROFILE)
+
+AC_OUTPUT(Makefile)