summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTim Terriberry <tterribe@xiph.org>2010-08-31 19:10:31 +0000
committerTim Terriberry <tterribe@xiph.org>2010-08-31 19:10:31 +0000
commit8886a2805fc107489912f8c500db3373e04a316d (patch)
tree42854e1ade8a2b627c52f2482bf27793054c0523 /configure.in
parent7125eb6381e57436db1c5a2d7c4e52091c37e95c (diff)
downloadtremor-8886a2805fc107489912f8c500db3373e04a316d.tar.gz
Convert Tremor to use libogg instead of its own internal libogg2.
This makes it easier to use Tremor as a drop-in replacement for libvorbis and reduces code size and overhead for those who don't want to use its built-in Ogg demuxer. This commit also backports all of the changes that have accumulated in libvorbis's vorbisfile implementation, with the exception of halfrate decoding and cross-lapped seeking. Those should not be too hard to add if someone really wants them. git-svn-id: https://svn.xiph.org/trunk/Tremor@17375 0101bb08-14d6-0310-b084-bc0e0c8e3800
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3ecbe97..7e0ff2a 100644
--- a/configure.in
+++ b/configure.in
@@ -115,6 +115,27 @@ dnl --------------------------------------------------
dnl none
dnl --------------------------------------------------
+dnl Check for libraries
+dnl --------------------------------------------------
+
+PKG_PROG_PKG_CONFIG
+
+HAVE_OGG=no
+if test "x$PKG_CONFIG" != "x"
+then
+ PKG_CHECK_MODULES(OGG, ogg >= 1.0, HAVE_OGG=yes, HAVE_OGG=no)
+fi
+if test "x$HAVE_OGG" = "xno"
+then
+ dnl fall back to the old school test
+ XIPH_PATH_OGG(, AC_MSG_ERROR(must have Ogg installed!))
+ libs_save=$LIBS
+ LIBS="$OGG_LIBS"
+ AC_CHECK_FUNC(oggpack_writealign, , AC_MSG_ERROR(Ogg >= 1.0 required !))
+ LIBS=$libs_save
+fi
+
+dnl --------------------------------------------------
dnl Check for library functions
dnl --------------------------------------------------