summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBernd Schubert <bs@q-leap.de>2008-06-03 11:01:32 +0200
committerBernd Schubert <bs@q-leap.de>2008-06-03 11:01:32 +0200
commit547752381f5f0fa284074a273291316786d3e083 (patch)
tree0fab2fce295b6236f5666cadc56b84db35589baa /CMakeLists.txt
parentf2633e093d3f8a96cb6b16d056a0b01075acefec (diff)
downloadunionfs-fuse-git-547752381f5f0fa284074a273291316786d3e083.tar.gz
Fix a bug in path_is_dir(), we need to use lstat(). Thanks to Radek for noticing!
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2a823a6..fca12ea 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,7 @@ IF(NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE)
ENDIF(NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE)
# Select flags.
-SET(CMAKE_C_FLAGS "-Wall")
+SET(CMAKE_C_FLAGS "-Wall -DFORTIFY_SOURCE=2")
SET(CMAKE_C_FLAGS_RELWITHDEBINFO "-O2 -g")
SET(CMAKE_C_FLAGS_RELEASE "-O2")
SET(CMAKE_C_FLAGS_DEBUG "-O0 -g")