summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRadek Podgorny <radek@podgorny.cz>2008-06-30 14:20:56 +0200
committerRadek Podgorny <radek@podgorny.cz>2008-06-30 14:20:56 +0200
commit601eceab3572b7c7b6a5585df7b40e997d169b68 (patch)
treec7c496c6d73a36d67c311fc1934639c53fd7cd2b /CMakeLists.txt
parent2d7efc9ab55accbb9bb3140f30eb7889284068e7 (diff)
downloadunionfs-fuse-git-601eceab3572b7c7b6a5585df7b40e997d169b68.tar.gz
Ported cmake files to new dir structure
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt30
1 files changed, 2 insertions, 28 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5698feb..f6aebc5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,30 +1,4 @@
project(unionfs-fuse)
-# Set a default build type for single-configuration
-# CMake generators if no build type is set.
-IF(NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE)
- SET(CMAKE_BUILD_TYPE RelWithDebInfo)
-ENDIF(NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE)
-
-# Select flags.
-SET(CMAKE_C_FLAGS "-pipe -W -Wall -DFORTIFY_SOURCE=2")
-SET(CMAKE_C_FLAGS_RELWITHDEBINFO "-O2 -g")
-SET(CMAKE_C_FLAGS_RELEASE "-O2")
-SET(CMAKE_C_FLAGS_DEBUG "-O0 -g")
-
-add_definitions(-D_FILE_OFFSET_BITS=64 -DFUSE_USE_VERSION=26)
-
-option(WITH_XATTR "Enable support for extended attributes")
-if(WITH_XATTR)
- add_definitions(-DHAVE_SETXATTR)
-endif(WITH_XATTR)
-
-set(HASHTABLE_SRCS hashtable.c hashtable_itr.c)
-set(UNIONFS_SRCS unionfs.c stats.c opts.c debug.c findbranch.c readdir.c general.c unlink.c cow.c cow_utils.c string.c rmdir.c)
-
-add_executable(unionfs ${UNIONFS_SRCS} ${HASHTABLE_SRCS})
-target_link_libraries(unionfs fuse pthread m rt)
-
-INSTALL(PROGRAMS unionfs DESTINATION sbin)
-INSTALL(FILES unionfs-fuse.8 DESTINATION share/man/man8/)
-
+add_subdirectory(src)
+add_subdirectory(man)