summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRadek Podgorny <radek@podgorny.cz>2022-01-04 21:31:43 +0100
committerRadek Podgorny <radek@podgorny.cz>2022-01-04 21:31:43 +0100
commit91a8b183540979a8cd4f108f0d8ceeb5082b070c (patch)
treeeeaaea85154b1f53cced388cdb16ca048015644e /CMakeLists.txt
parent3a112d9196c5076ed3faabcf76187f29ed9f1eae (diff)
downloadunionfs-fuse-git-91a8b183540979a8cd4f108f0d8ceeb5082b070c.tar.gz
enable xattrs in cmake by default
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e904d78..4726324 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,7 +4,7 @@ project(unionfs-fuse VERSION 2.3
DESCRIPTION "user-space implementation of union filesystem (with help of fuse)"
LANGUAGES C)
-INCLUDE (CheckIncludeFiles)
+INCLUDE(CheckIncludeFiles)
# Set a default build type for single-configuration
# CMake generators if no build type is set.
@@ -12,9 +12,8 @@ IF(NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE)
SET(CMAKE_BUILD_TYPE RelWithDebInfo)
ENDIF(NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE)
-option(WITH_XATTR "Enable support for extended attributes" OFF)
+option(WITH_XATTR "Enable support for extended attributes" ON)
-# .h include files
IF (WITH_XATTR)
CHECK_INCLUDE_FILES("sys/xattr.h" HAVE_LIBC_XATTR)
CHECK_INCLUDE_FILES("attr/xattr.h" HAVE_LIBATTR_XATTR)