summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBernd Schubert <bs@q-leap.de>2008-06-03 11:01:32 +0200
committerBernd Schubert <bs@q-leap.de>2008-06-03 11:01:32 +0200
commit6b5dc0b1fe744392746026cc156a077e87c5e33f (patch)
treeecdae396a0878260363877fd08513cb4906ca966 /CMakeLists.txt
parent7f813594802d0b6e1c83607063e2456931095cb4 (diff)
downloadunionfs-fuse-6b5dc0b1fe744392746026cc156a077e87c5e33f.tar.gz
Fix a bug in path_is_dir(), we need to use lstat(). Thanks to Radek for noticing!
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2a823a6..fca12ea 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,7 @@ IF(NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE)
ENDIF(NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE)
# Select flags.
-SET(CMAKE_C_FLAGS "-Wall")
+SET(CMAKE_C_FLAGS "-Wall -DFORTIFY_SOURCE=2")
SET(CMAKE_C_FLAGS_RELWITHDEBINFO "-O2 -g")
SET(CMAKE_C_FLAGS_RELEASE "-O2")
SET(CMAKE_C_FLAGS_DEBUG "-O0 -g")