summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 6 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 0284d1f..5c3425c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,6 +9,10 @@
# Uncomment this to turn on verbose mode.
export DH_VERBOSE=1
+QUILT_STAMPFN := patch-stamp
+include /usr/share/quilt/quilt.make
+
+
CFLAGS = -pipe -W -Wall -g
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
@@ -32,7 +36,7 @@ configure-stamp:
build: build-stamp
-build-stamp: configure-stamp
+build-stamp: $(QUILT_STAMPFN) configure-stamp
dh_testdir
# Add here commands to compile the package.
@@ -43,7 +47,7 @@ build-stamp: configure-stamp
clean: unpatch
dh_testdir
dh_testroot
- rm -f build-stamp configure-stamp
+ rm -f build-stamp configure-stamp $(QUILT_STAMPFN)
# Add here commands to clean up after the build process.
rm -fr debian/build