summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index d58d4f4..a6511c7 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -3,6 +3,10 @@ set(UNIONFS_SRCS unionfs.c stats.c opts.c debug.c findbranch.c readdir.c
general.c unlink.c cow.c cow_utils.c string.c rmdir.c usyslog.c)
add_executable(unionfs ${UNIONFS_SRCS} ${HASHTABLE_SRCS})
-target_link_libraries(unionfs fuse pthread rt)
+target_link_libraries(unionfs fuse pthread)
+
+if (UNIX AND NOT APPLE)
+ target_link_libraries(rt)
+endif()
INSTALL(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/unionfs DESTINATION bin)