summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBenjamin Berg <bberg@redhat.com>2022-02-07 15:56:48 +0100
committerBenjamin Berg <bberg@redhat.com>2022-02-07 15:59:13 +0100
commitda05dd4b81d92bf5600ef768e8b26f6b1db3a62d (patch)
treec6f4f83f6070e4bdf752b3b3db7a1b569894c233 /meson.build
parentfb02a57a2b9eac0527d7644e3e394e6d709fa182 (diff)
downloadupower-da05dd4b81d92bf5600ef768e8b26f6b1db3a62d.tar.gz
meson: Return a disabler if xsltproc is not found
Fixes: #170
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 2d9b9c0..2f2dfbe 100644
--- a/meson.build
+++ b/meson.build
@@ -47,7 +47,7 @@ gio_dep = dependency('gio-2.0', version: '>=' + glib_min_version)
gio_unix_dep = dependency('gio-unix-2.0', version: '>=' + glib_min_version)
m_dep = cc.find_library('m', required: true)
-xsltproc = find_program('xsltproc', required: get_option('gtk-doc') or get_option('man'))
+xsltproc = find_program('xsltproc', disabler: true, required: get_option('gtk-doc') or get_option('man'))
# Resolve OS backend
os_backend = get_option('os_backend')