summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2022-02-07 11:09:21 +0100
committerBenjamin Berg <bberg@redhat.com>2022-02-07 13:57:27 +0100
commitf596bd016449813f4a9482925ead1938da52f8ba (patch)
treee20e85254c4a1fea6b6383e85f211d7139463095 /meson.build
parent1dc74629ff24a2121f17f6e38b2c8067be0b7182 (diff)
downloadupower-f596bd016449813f4a9482925ead1938da52f8ba.tar.gz
build: Fix missing libm link on some platforms
This should fix the PPC64 and ARMv7 builds.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 3858cbe..2d9b9c0 100644
--- a/meson.build
+++ b/meson.build
@@ -45,6 +45,7 @@ glib_dep = dependency('glib-2.0', version: '>=' + glib_min_version)
gobject_dep = dependency('gobject-2.0', version: '>=' + glib_min_version)
gio_dep = dependency('gio-2.0', version: '>=' + glib_min_version)
gio_unix_dep = dependency('gio-unix-2.0', version: '>=' + glib_min_version)
+m_dep = cc.find_library('m', required: true)
xsltproc = find_program('xsltproc', required: get_option('gtk-doc') or get_option('man'))