summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2021-04-15 10:06:47 +0200
committerJonas Ã…dahl <jadahl@gmail.com>2021-09-01 07:14:00 +0000
commit26843d6155879ae16f444cf4962ba37385e859b0 (patch)
tree38713490fb45a8fd3eae6ca8e5db429095ee93c5 /meson.build
parent62e862fac42a5f4013a792575ad112252978164e (diff)
downloadwayland-protocols-26843d6155879ae16f444cf4962ba37385e859b0.tar.gz
build: declare dependency for use as a subproject
This allows clients and compositors to easily use wayland-protocols as a Meson subproject. Signed-off-by: Simon Ser <contact@emersion.fr>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 9 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 4febb24..cba88a1 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,6 @@
project('wayland-protocols',
version: '1.21',
- meson_version: '>= 0.53.0',
+ meson_version: '>= 0.54.0',
license: 'MIT/Expat',
)
@@ -107,6 +107,14 @@ configure_file(
configuration: pkgconfig_configuration,
)
+wayland_protocols = declare_dependency(
+ variables: {
+ 'pkgdatadir': wayland_protocols_srcdir,
+ },
+)
+
+meson.override_dependency('wayland-protocols', wayland_protocols)
+
if get_option('tests')
subdir('tests')
endif