summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorXaver Hugl <xaver.hugl@gmail.com>2021-05-06 15:16:20 +0200
committerSimon Ser <contact@emersion.fr>2021-08-06 07:03:19 +0000
commitaa3df4084af54c9622f864bcae093da2f8f55b89 (patch)
tree2a6615201236fbe6cbe5a027468d5bdda5e9a9a8 /meson.build
parent7460f79e4b10bcba20f32af28286955ecf0b9105 (diff)
downloadwayland-protocols-aa3df4084af54c9622f864bcae093da2f8f55b89.tar.gz
staging/drm-lease: DRM lease protocol support
DRM leasing is a feature which allows the DRM master to "lease" a subset of its DRM resources to another DRM master via drmModeCreateLease, which returns a file descriptor for the new DRM master. We use this protocol to negotiate the terms of the lease and transfer this file descriptor to clients. In less DRM-specific terms: this protocol allows Wayland compositors to give over their GPU resources (like displays) to a Wayland client to exclusively control. The primary use-case for this is Virtual Reality headsets, which via the non-desktop DRM property are generally not used as desktop displays by Wayland compositors, and for latency reasons (among others) are most useful to games et al if they have direct control over the DRM resources associated with it. Basically, these are peripherals which are of no use to the compositor and may be of use to a client, but since they are tied up in DRM we need to use DRM leasing to get them into client's hands. Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Signed-off-by: Drew DeVault <sir@cmpwn.com> Signed-off-by: Xaver Hugl <xaver.hugl@gmail.com> Reviewed-by: Simon Ser <contact@emersion.fr> Signed-off-by: David Edmundson <davidedmundson@kde.org> Reviewed-by: Jonas Ã…dahl <jadahl@gmail.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 2921c7d..4febb24 100644
--- a/meson.build
+++ b/meson.build
@@ -39,6 +39,7 @@ unstable_protocols = {
staging_protocols = {
'xdg-activation': ['v1'],
+ 'drm-lease': ['v1'],
}
protocol_files = []