summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAlex Richardson <Alexander.Richardson@cl.cam.ac.uk>2021-03-15 22:25:52 +0000
committerAlexander Richardson <alexander.richardson@cl.cam.ac.uk>2021-09-10 11:35:54 +0000
commit5a981ee823795a61372c46ed7f6d2582450ee0af (patch)
tree12c0c554e8577dd0d06bce8bc7ba481ece3a8311 /meson.build
parent54b237a61257a41d35d018c5871331bdf1df77a6 (diff)
downloadwayland-5a981ee823795a61372c46ed7f6d2582450ee0af.tar.gz
shm: Add mmap+memmove fallback if mremap() does not exist
Some operating systems (e.g. FreeBSD) do not implement mremap. In that case we can grow the mapping by trying to map adjacent memory. If that fails we can fall back to creating a new larger mapping and moving the old memory contents there. Co-authored-by: Koop Mast <kwm@rainbow-runner.nl> Signed-off-by: Alex Richardson <Alexander.Richardson@cl.cam.ac.uk>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index aeb171e..239bff7 100644
--- a/meson.build
+++ b/meson.build
@@ -36,6 +36,7 @@ have_funcs = [
'posix_fallocate',
'prctl',
'memfd_create',
+ 'mremap',
'strndup',
]
foreach f: have_funcs