summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAlex Richardson <Alexander.Richardson@cl.cam.ac.uk>2021-03-15 22:37:49 +0000
committerAlexander Richardson <alexander.richardson@cl.cam.ac.uk>2021-09-10 11:35:54 +0000
commitbb928288077ff0fcab50a881e1ade2cf249f7a14 (patch)
tree965ef48d243a79989398d8e182cda7ea4d97593e /meson.build
parent644efe9517eb48d18decc33d5bed5276fcdd2f5a (diff)
downloadwayland-bb928288077ff0fcab50a881e1ade2cf249f7a14.tar.gz
test-runner: Implement is_debugger_attached() for FreeBSD
FreeBSD provides a PROC_TRACE_STATUS procctl(2) to detect this directly. Signed-off-by: Alex Richardson <Alexander.Richardson@cl.cam.ac.uk>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 239bff7..a116d9d 100644
--- a/meson.build
+++ b/meson.build
@@ -26,7 +26,7 @@ add_project_arguments(
language: 'c'
)
-foreach h: [ 'sys/prctl.h', 'sys/ucred.h' ]
+foreach h: [ 'sys/prctl.h', 'sys/procctl.h', 'sys/ucred.h' ]
config_h.set('HAVE_' + h.underscorify().to_upper(), cc.has_header(h))
endforeach