summaryrefslogtreecommitdiff
path: root/webrtc/base/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'webrtc/base/meson.build')
-rw-r--r--webrtc/base/meson.build34
1 files changed, 34 insertions, 0 deletions
diff --git a/webrtc/base/meson.build b/webrtc/base/meson.build
new file mode 100644
index 0000000..2f634a3
--- /dev/null
+++ b/webrtc/base/meson.build
@@ -0,0 +1,34 @@
+base_sources = [
+ 'criticalsection.cc',
+ 'checks.cc',
+ 'event.cc',
+ 'platform_thread.cc',
+ 'platform_file.cc',
+ 'stringutils.cc',
+ 'thread_checker_impl.cc',
+]
+
+base_headers = [
+ 'arraysize.h',
+ 'checks.h',
+ 'constructormagic.h',
+ 'basictypes.h',
+ 'maybe.h',
+ 'platform_file.h',
+]
+
+install_headers(base_headers,
+ subdir: 'webrtc_audio_processing/webrtc/base'
+)
+
+libbase = static_library('libbase',
+ base_sources,
+ dependencies: common_deps,
+ include_directories: webrtc_inc,
+ cpp_args : common_cxxflags
+)
+
+base_dep = declare_dependency(
+ link_with: libbase
+)
+