summaryrefslogtreecommitdiff
path: root/webrtc/system_wrappers/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'webrtc/system_wrappers/meson.build')
-rw-r--r--webrtc/system_wrappers/meson.build41
1 files changed, 6 insertions, 35 deletions
diff --git a/webrtc/system_wrappers/meson.build b/webrtc/system_wrappers/meson.build
index c8cb9ed..22a9a1b 100644
--- a/webrtc/system_wrappers/meson.build
+++ b/webrtc/system_wrappers/meson.build
@@ -1,47 +1,18 @@
system_wrappers_sources = [
- 'source/aligned_malloc.cc',
'source/cpu_features.cc',
- 'source/event.cc',
- 'source/file_impl.cc',
- 'source/critical_section.cc',
- 'source/logging.cc',
- 'source/metrics_default.cc',
- 'source/rw_lock.cc',
+ 'source/field_trial.cc',
+ 'source/metrics.cc',
'source/sleep.cc',
- 'source/thread.cc',
- 'source/trace_impl.cc',
]
-if have_posix
- system_wrappers_sources += [
- 'source/critical_section_posix.cc',
- 'source/event_timer_posix.cc',
- 'source/rw_lock_posix.cc',
- 'source/thread_posix.cc',
- 'source/trace_posix.cc',
- ]
-endif
-
-if have_win
- system_wrappers_sources += [
- 'source/critical_section_win.cc',
- 'source/condition_variable.cc',
- 'source/condition_variable_event_win.cc',
- 'source/condition_variable_native_win.cc',
- 'source/event_timer_win.cc',
- 'source/rw_lock_win.cc',
- 'source/rw_lock_generic.cc',
- 'source/thread_win.cc',
- 'source/trace_win.cc',
- ]
-endif
-
system_headers = [
- 'include/trace.h',
+ 'include/cpu_features_wrapper.h',
+ 'include/metrics.h',
+ 'include/sleep.h',
]
install_headers(system_headers,
- subdir: 'webrtc_audio_processing/webrtc/system_wrappers/include'
+ subdir: 'webrtc_audio_processing/system_wrappers/include'
)
libsystem_wrappers = static_library('system_wrappers',