summaryrefslogtreecommitdiff
path: root/webrtc/third_party/pffft/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'webrtc/third_party/pffft/meson.build')
-rw-r--r--webrtc/third_party/pffft/meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/webrtc/third_party/pffft/meson.build b/webrtc/third_party/pffft/meson.build
new file mode 100644
index 0000000..c1eb5c6
--- /dev/null
+++ b/webrtc/third_party/pffft/meson.build
@@ -0,0 +1,21 @@
+pffft_sources = [
+ 'src/pffft.c',
+]
+
+pffft_cflags = [ '-D_GNU_SOURCE' ]
+
+if (have_arm and not have_neon) or (have_mips and host_machine.endian() == 'little') or have_mips64
+ pffft_cflags += [ '-DPFFFT_SIMD_DISABLE' ]
+endif
+
+libpffft = static_library('libpffft',
+ pffft_sources,
+ dependencies: common_deps,
+ include_directories: webrtc_inc,
+ c_args : common_cflags + pffft_cflags
+)
+
+pffft_dep = declare_dependency(
+ link_with: libpffft
+)
+